What’s Vulnerable › Vulnerabilities
CVE-2022-4833: YourChannel: Everything you want in a YouTube plugin < 1.2.3 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
Description
The YourChannel: Everything you want in a YouTube plugin WordPress plugin before 1.2.3 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- pluginbuilders YourChannel: Everything you want in a YouTube plugin.: before 1.2.3 — fixed in 1.2.3
How to fix
Upgrade to a fixed version: pluginbuilders YourChannel: Everything you want in a YouTube plugin. 1.2.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/35ba38cf-4f23-4344-8de3-cf3004ebf84c
- https://wpscan.com/vulnerability/35ba38cf-4f23-4344-8de3-cf3004ebf84c
Get alerted when CVE-2022-4833 or the next vulnerability affects your stack