What’s Vulnerable › Vulnerabilities
CVE-2022-4837: CPO Companion < 1.1.0 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The CPO Companion WordPress plugin before 1.1.0 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- CPO Companion: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: CPO Companion 1.1.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/41abeacb-ef3e-4621-89bb-df0f2eb617da
- https://wpscan.com/vulnerability/41abeacb-ef3e-4621-89bb-df0f2eb617da
Get alerted when CVE-2022-4837 or the next vulnerability affects your stack