What’s Vulnerable › Vulnerabilities
CVE-2022-4838: Clean Login < 1.13.7 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Clean Login WordPress plugin before 1.13.7 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Clean Login: before 1.13.7 — fixed in 1.13.7
How to fix
Upgrade to a fixed version: Clean Login 1.13.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9937e369-60e8-451c-8790-1a83a59115fc
- https://wpscan.com/vulnerability/9937e369-60e8-451c-8790-1a83a59115fc
Get alerted when CVE-2022-4838 or the next vulnerability affects your stack