What’s Vulnerable › Vulnerabilities
CVE-2022-4841: Cross-site Scripting (XSS) - Stored in usememos/memos
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-29 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.
Affected products
- usememos/memos: before 0.9.1 — fixed in 0.9.1
How to fix
Upgrade to a fixed version: usememos/memos 0.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/usememos/memos/commit/64e5c343c5f74b0abdf3ac0d21a6139daea58cf8
- https://huntr.dev/bounties/fa46b3ef-c621-443a-be3a-0a83fb78ba62
- https://github.com/usememos/memos/commit/64e5c343c5f74b0abdf3ac0d21a6139daea58cf8
- https://huntr.dev/bounties/fa46b3ef-c621-443a-be3a-0a83fb78ba62
Get alerted when CVE-2022-4841 or the next vulnerability affects your stack