What’s Vulnerable › Vulnerabilities
CVE-2022-48619
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-12 · updated 2026-06-17
- Weakness: CWE-755
Description
An issue was discovered in drivers/input/input.c in the Linux kernel before 5.17.10. An attacker can cause a denial of service (panic) because input_set_capability mishandles the situation in which an event code falls outside of a bitmap.
Affected products
- Linux kernel: before 5.17.10 — fixed in 5.17.10
How to fix
Upgrade to a fixed version: Linux kernel 5.17.10. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.17.10
- https://github.com/torvalds/linux/commit/409353cbe9fe48f6bc196114c442b1cff05a39bc
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.17.10
- https://github.com/torvalds/linux/commit/409353cbe9fe48f6bc196114c442b1cff05a39bc
Get alerted when CVE-2022-48619 or the next vulnerability affects your stack