What’s Vulnerable › Vulnerabilities
CVE-2022-48647: sfc: fix TX channel offset when using legacy interrupts
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-28 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: sfc: fix TX channel offset when using legacy interrupts In legacy interrupt mode the tx_channel_offset was hardcoded to 1, but that's not correct if efx_sepparate_tx_channels is false. In that case, the offset is 0 because the tx queues are in the single existing channel at index 0, together with the rx queue. Without this fix, as soon as you try to send any traffic, it tries to get the tx queues from an uninitialized channel getting these errors: WARNING: CPU: 1 PID: 0 at drivers/net/ethernet/sfc/tx.c:540 efx_hard_start_xmit+0x12e/0x170 [sfc] [...] RIP: 0010:efx_hard_start_xmit+0x12e/0x170 [sfc] [...] Call Trace: <IRQ> dev_hard_start_xmit+0xd7/0x230 sch_direct_xmit+0x9f/0x360 __dev_queue_xmit+0x890/0xa40 [...] BUG: unable to handle kernel NULL pointer dereference at 0000000000000020 [...] RIP: 0010:efx_hard_start_xmit+0x153/0x170 [sfc] [...] Call Trace: <IRQ> dev_hard_start_xmit+0xd7/0x230 sch_direct_xmit+0x9f/0x360 __dev_queue_xmit+0x890/0xa40 [...]
Affected products
- Linux kernel: from 5.10.122 before 5.10.146; from 5.15.47 before 5.15.71; from 5.17.15 before 5.18; from 5.18.4 before 5.19.12; 6.0-rc1, 6.0-rc2, 6.0-rc3, 6.0-rc4, 6.0-rc5, 6.0-rc6 — fixed in 5.10.146, 5.15.71, 5.18, 5.19.12
How to fix
Upgrade to a fixed version: Linux kernel 5.10.146, 5.15.71, 5.18, 5.19.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/360910b88d1466a90644a4e0533803b594344a2b
- https://git.kernel.org/stable/c/5f623a77cfc2d501d72bcb4f9ee71721e6c766ff
- https://git.kernel.org/stable/c/b4afd3878f961d3517f27b3213730fceef77945c
- https://git.kernel.org/stable/c/f232af4295653afa4ade3230462b3be15ad16419
- https://git.kernel.org/stable/c/360910b88d1466a90644a4e0533803b594344a2b
- https://git.kernel.org/stable/c/5f623a77cfc2d501d72bcb4f9ee71721e6c766ff
- https://git.kernel.org/stable/c/b4afd3878f961d3517f27b3213730fceef77945c
- https://git.kernel.org/stable/c/f232af4295653afa4ade3230462b3be15ad16419
Get alerted when CVE-2022-48647 or the next vulnerability affects your stack