What’s Vulnerable › Vulnerabilities
CVE-2022-4865: Cross-site Scripting (XSS) - Stored in usememos/memos
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.1.
Affected products
- usememos/memos: before 0.9.1 — fixed in 0.9.1
How to fix
Upgrade to a fixed version: usememos/memos 0.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/usememos/memos/commit/7670c9536000bb32c6345d4906a91268dcddd5fc
- https://huntr.dev/bounties/cd8765a2-bf28-4019-8647-882ccf63b2be
- https://github.com/usememos/memos/commit/7670c9536000bb32c6345d4906a91268dcddd5fc
- https://huntr.dev/bounties/cd8765a2-bf28-4019-8647-882ccf63b2be
Get alerted when CVE-2022-4865 or the next vulnerability affects your stack