What’s Vulnerable › Vulnerabilities
CVE-2022-48672: of: fdt: fix off-by-one error in unflatten_dt_nodes()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-193
Description
In the Linux kernel, the following vulnerability has been resolved: of: fdt: fix off-by-one error in unflatten_dt_nodes() Commit 78c44d910d3e ("drivers/of: Fix depth when unflattening devicetree") forgot to fix up the depth check in the loop body in unflatten_dt_nodes() which makes it possible to overflow the nps[] buffer... Found by Linux Verification Center (linuxtesting.org) with the SVACE static analysis tool.
Affected products
- Linux kernel: from 4.7 before 4.14.295; from 4.15 before 4.19.260; from 4.20 before 5.4.215; from 5.5 before 5.10.145; from 5.11 before 5.15.70; from 5.16 before 5.19.11 — fixed in 4.14.295, 4.19.260, 5.10.145, 5.15.70, 5.19.11, 5.4.215
How to fix
Upgrade to a fixed version: Linux kernel 4.14.295, 4.19.260, 5.10.145, 5.15.70. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2133f451311671c7c42b5640d2b999326b39aa0e
- https://git.kernel.org/stable/c/2566706ac6393386a4e7c4ce23fe17f4c98d9aa0
- https://git.kernel.org/stable/c/2f945a792f67815abca26fa8a5e863ccf3fa1181
- https://git.kernel.org/stable/c/ba6b9f7cc1108bad6e2c53b1d6e0156379188db7
- https://git.kernel.org/stable/c/cbdda20ce363356698835185801a58a28f644853
- https://git.kernel.org/stable/c/e0e88c25f88b9805572263c9ed20f1d88742feaf
- https://git.kernel.org/stable/c/ee4369260e77821602102dcc7d792de39a56365c
- https://git.kernel.org/stable/c/2133f451311671c7c42b5640d2b999326b39aa0e
- https://git.kernel.org/stable/c/2566706ac6393386a4e7c4ce23fe17f4c98d9aa0
- https://git.kernel.org/stable/c/2f945a792f67815abca26fa8a5e863ccf3fa1181
- https://git.kernel.org/stable/c/ba6b9f7cc1108bad6e2c53b1d6e0156379188db7
- https://git.kernel.org/stable/c/cbdda20ce363356698835185801a58a28f644853
Get alerted when CVE-2022-48672 or the next vulnerability affects your stack