What’s Vulnerable › Vulnerabilities
CVE-2022-4870
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-18 · updated 2026-06-17
- Weakness: CWE-209
Description
In affected versions of Octopus Deploy it is possible to discover network details via error message
Affected products
- Octopus Deploy Octopus Server: from 3.0.0 before 2023.1.9879; from 2023.2.2028 before 2023.2.8159 — fixed in 2023.1.9879, 2023.2.8159
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2023.1.9879, 2023.2.8159. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2023/sa2023-09/
- https://advisories.octopus.com/post/2023/sa2023-09/
Get alerted when CVE-2022-4870 or the next vulnerability affects your stack