What’s Vulnerable › Vulnerabilities
CVE-2022-48708: pinctrl: single: fix potential NULL dereference
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-21 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: pinctrl: single: fix potential NULL dereference Added checking of pointer "function" in pcs_set_mux(). pinmux_generic_get_function() can return NULL and the pointer "function" was dereferenced without checking against NULL. Found by Linux Verification Center (linuxtesting.org) with SVACE.
Affected products
- Linux kernel: from 4.11 before 4.14.306; from 4.15 before 4.19.273; from 4.20 before 5.4.232; from 5.5 before 5.10.168; from 5.11 before 5.15.94; from 5.16 before 6.1.12 — fixed in 4.14.306, 4.19.273, 5.10.168, 5.15.94, 5.4.232, 6.1.12
How to fix
Upgrade to a fixed version: Linux kernel 4.14.306, 4.19.273, 5.10.168, 5.15.94. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1177bdafe87cbe543a2dc48a9bbac265aa5864db
- https://git.kernel.org/stable/c/2b763f7de108cb1a5ad5ed08e617d677341947cb
- https://git.kernel.org/stable/c/6e2a0521e4e84a2698f2da3950fb5c5496a4d208
- https://git.kernel.org/stable/c/71668706fbe7d20e6f172fa3287fa8aac1b56c26
- https://git.kernel.org/stable/c/bcc487001a15f71f103d102cba4ac8145d7a68f2
- https://git.kernel.org/stable/c/d2d73e6d4822140445ad4a7b1c6091e0f5fe703b
- https://git.kernel.org/stable/c/e671e63587c92b3fd767cf82e73129f6d5feeb33
- https://git.kernel.org/stable/c/1177bdafe87cbe543a2dc48a9bbac265aa5864db
- https://git.kernel.org/stable/c/2b763f7de108cb1a5ad5ed08e617d677341947cb
- https://git.kernel.org/stable/c/6e2a0521e4e84a2698f2da3950fb5c5496a4d208
- https://git.kernel.org/stable/c/71668706fbe7d20e6f172fa3287fa8aac1b56c26
- https://git.kernel.org/stable/c/bcc487001a15f71f103d102cba4ac8145d7a68f2
Get alerted when CVE-2022-48708 or the next vulnerability affects your stack