What’s Vulnerable › Vulnerabilities
CVE-2022-48730: dma-buf: heaps: Fix potential spectre v1 gadget
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-20 · updated 2026-06-17
- Weakness: CWE-203
Description
In the Linux kernel, the following vulnerability has been resolved: dma-buf: heaps: Fix potential spectre v1 gadget It appears like nr could be a Spectre v1 gadget as it's supplied by a user and used as an array index. Prevent the contents of kernel memory from being leaked to userspace via speculative execution by using array_index_nospec. [sumits: added fixes and cc: stable tags]
Affected products
- Linux kernel: from 5.6 before 5.10.99; from 5.11 before 5.15.22; from 5.16 before 5.16.8; 5.17-rc1, 5.17-rc2 — fixed in 5.10.99, 5.15.22, 5.16.8
How to fix
Upgrade to a fixed version: Linux kernel 5.10.99, 5.15.22, 5.16.8. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/24f8e12d965b24f8aea762589e0e9fe2025c005e
- https://git.kernel.org/stable/c/5d40f1bdad3dd1a177f21a90ad4353c1ed40ba3a
- https://git.kernel.org/stable/c/92c4cfaee6872038563c5b6f2e8e613f9d84d47d
- https://git.kernel.org/stable/c/cc8f7940d9c2d45f67b3d1a2f2b7a829ca561bed
- https://git.kernel.org/stable/c/24f8e12d965b24f8aea762589e0e9fe2025c005e
- https://git.kernel.org/stable/c/5d40f1bdad3dd1a177f21a90ad4353c1ed40ba3a
- https://git.kernel.org/stable/c/92c4cfaee6872038563c5b6f2e8e613f9d84d47d
- https://git.kernel.org/stable/c/cc8f7940d9c2d45f67b3d1a2f2b7a829ca561bed
Get alerted when CVE-2022-48730 or the next vulnerability affects your stack