What’s Vulnerable › Vulnerabilities
CVE-2022-48743: net: amd-xgbe: Fix skb data length underflow
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-20 · updated 2026-08-04
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: net: amd-xgbe: Fix skb data length underflow There will be BUG_ON() triggered in include/linux/skbuff.h leading to intermittent kernel panic, when the skb length underflow is detected. Fix this by dropping the packet if such length underflows are seen because of inconsistencies in the hardware descriptors.
Affected products
- Linux kernel: from 4.9.19 before 4.9.300; from 4.11 before 4.14.265; from 4.15 before 4.19.228; from 4.20 before 5.4.177; from 5.5 before 5.10.97; from 5.11 before 5.15.20 — fixed in 4.14.265, 4.19.228, 4.9.300, 5.10.97, 5.15.20, 5.16.6
How to fix
Upgrade to a fixed version: Linux kernel 4.14.265, 4.19.228, 4.9.300, 5.10.97. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/34aeb4da20f93ac80a6291a2dbe7b9c6460e9b26
- https://git.kernel.org/stable/c/4d3fcfe8464838b3920bc2b939d888e0b792934e
- https://git.kernel.org/stable/c/5aac9108a180fc06e28d4e7fb00247ce603b72ee
- https://git.kernel.org/stable/c/617f9934bb37993b9813832516f318ba874bcb7d
- https://git.kernel.org/stable/c/9892742f035f7aa7dcd2bb0750effa486db89576
- https://git.kernel.org/stable/c/9924c80bd484340191e586110ca22bff23a49f2e
- https://git.kernel.org/stable/c/db6fd92316a254be2097556f01bccecf560e53ce
- https://git.kernel.org/stable/c/e8f73f620fee5f52653ed2da360121e4446575c5
- https://git.kernel.org/stable/c/34aeb4da20f93ac80a6291a2dbe7b9c6460e9b26
- https://git.kernel.org/stable/c/4d3fcfe8464838b3920bc2b939d888e0b792934e
- https://git.kernel.org/stable/c/5aac9108a180fc06e28d4e7fb00247ce603b72ee
- https://git.kernel.org/stable/c/617f9934bb37993b9813832516f318ba874bcb7d
Get alerted when CVE-2022-48743 or the next vulnerability affects your stack