What’s Vulnerable › Vulnerabilities
CVE-2022-48754: phylib: fix potential use-after-free
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-20 · updated 2026-08-04
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: phylib: fix potential use-after-free Commit bafbdd527d56 ("phylib: Add device reset GPIO support") added call to phy_device_reset(phydev) after the put_device() call in phy_detach(). The comment before the put_device() call says that the phydev might go away with put_device(). Fix potential use-after-free by calling phy_device_reset() before put_device().
Affected products
- Linux kernel: from 4.16 before 4.19.228; from 4.20 before 5.4.176; from 5.5 before 5.10.96; from 5.11 before 5.15.19; from 5.16 before 5.16.5; 5.17-rc1 — fixed in 4.19.228, 5.10.96, 5.15.19, 5.16.5, 5.4.176
How to fix
Upgrade to a fixed version: Linux kernel 4.19.228, 5.10.96, 5.15.19, 5.16.5. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/67d271760b037ce0806d687ee6057edc8afd4205
- https://git.kernel.org/stable/c/aefaccd19379d6c4620269a162bfb88ff687f289
- https://git.kernel.org/stable/c/bd024e36f68174b1793906c39ca16cee0c9295c2
- https://git.kernel.org/stable/c/cb2fab10fc5e7a3aa1bb0a68a3abdcf3e37852af
- https://git.kernel.org/stable/c/cbda1b16687580d5beee38273f6241ae3725960c
- https://git.kernel.org/stable/c/f39027cbada43b33566c312e6be3db654ca3ad17
- https://git.kernel.org/stable/c/67d271760b037ce0806d687ee6057edc8afd4205
- https://git.kernel.org/stable/c/aefaccd19379d6c4620269a162bfb88ff687f289
- https://git.kernel.org/stable/c/bd024e36f68174b1793906c39ca16cee0c9295c2
- https://git.kernel.org/stable/c/cb2fab10fc5e7a3aa1bb0a68a3abdcf3e37852af
- https://git.kernel.org/stable/c/cbda1b16687580d5beee38273f6241ae3725960c
- https://git.kernel.org/stable/c/f39027cbada43b33566c312e6be3db654ca3ad17
Get alerted when CVE-2022-48754 or the next vulnerability affects your stack