What’s Vulnerable › Vulnerabilities
CVE-2022-4876: Kaltura mwEmbed DefaultSettings.php cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-04 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in Kaltura mwEmbed up to 2.96.rc1 and classified as problematic. This issue affects some unknown processing of the file includes/DefaultSettings.php. The manipulation of the argument HTTP_X_FORWARDED_HOST leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.96.rc2 is able to address this issue. The patch is named 13b8812ebc8c9fa034eed91ab35ba8423a528c0b. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217427.
Affected products
- kaltura mwEmbed: through 2.95; 2.96-rc1
References
- https://github.com/kaltura/mwEmbed/commit/13b8812ebc8c9fa034eed91ab35ba8423a528c0b
- https://github.com/kaltura/mwEmbed/pull/4266
- https://github.com/kaltura/mwEmbed/releases/tag/v2.96.rc2
- https://vuldb.com/?ctiid.217427
- https://vuldb.com/?id.217427
- https://github.com/kaltura/mwEmbed/commit/13b8812ebc8c9fa034eed91ab35ba8423a528c0b
- https://github.com/kaltura/mwEmbed/pull/4266
- https://github.com/kaltura/mwEmbed/releases/tag/v2.96.rc2
- https://vuldb.com/?ctiid.217427
- https://vuldb.com/?id.217427
Get alerted when CVE-2022-4876 or the next vulnerability affects your stack