What’s Vulnerable › Vulnerabilities
CVE-2022-48778: mtd: rawnand: gpmi: don't leak PM reference in error path
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-16 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: mtd: rawnand: gpmi: don't leak PM reference in error path If gpmi_nfc_apply_timings() fails, the PM runtime usage counter must be dropped.
Affected products
- Linux kernel: from 5.4.174 before 5.4.181; from 5.10.94 before 5.10.102; from 5.15.17 before 5.15.25; from 5.16.3 before 5.16.11 — fixed in 5.10.102, 5.15.25, 5.16.11, 5.4.181
How to fix
Upgrade to a fixed version: Linux kernel 5.10.102, 5.15.25, 5.16.11, 5.4.181. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4a7ec50298b1127c5024a750c969ea0794899545
- https://git.kernel.org/stable/c/4cd3281a910a5adf73b2a0a82241dd67844d0b25
- https://git.kernel.org/stable/c/58d3111eafce9e4398654b07f0b1dac27f26ee5b
- https://git.kernel.org/stable/c/9161f365c91614e5a3f5c6dcc44c3b1b33bc59c0
- https://git.kernel.org/stable/c/a4eeeaca50199e3f19eb13ac3b7e0bbb93e22de4
- https://git.kernel.org/stable/c/4a7ec50298b1127c5024a750c969ea0794899545
- https://git.kernel.org/stable/c/4cd3281a910a5adf73b2a0a82241dd67844d0b25
- https://git.kernel.org/stable/c/58d3111eafce9e4398654b07f0b1dac27f26ee5b
- https://git.kernel.org/stable/c/9161f365c91614e5a3f5c6dcc44c3b1b33bc59c0
- https://git.kernel.org/stable/c/a4eeeaca50199e3f19eb13ac3b7e0bbb93e22de4
Get alerted when CVE-2022-48778 or the next vulnerability affects your stack