What’s Vulnerable › Vulnerabilities
CVE-2022-48789: nvme-tcp: fix possible use-after-free in transport error_recovery work
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-16 · updated 2026-08-04
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: nvme-tcp: fix possible use-after-free in transport error_recovery work While nvme_tcp_submit_async_event_work is checking the ctrl and queue state before preparing the AER command and scheduling io_work, in order to fully prevent a race where this check is not reliable the error recovery work must flush async_event_work before continuing to destroy the admin queue after setting the ctrl state to RESETTING such that there is no race .submit_async_event and the error recovery handler itself changing the ctrl state.
Affected products
- Linux kernel: before 5.4.181; from 5.5 before 5.10.102; from 5.11 before 5.15.25; from 5.16 before 5.16.11 — fixed in 5.10.102, 5.15.25, 5.16.11, 5.4.181
How to fix
Upgrade to a fixed version: Linux kernel 5.10.102, 5.15.25, 5.16.11, 5.4.181. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/5e42fca37ccc76f39f73732661bd47254cad5982
- https://git.kernel.org/stable/c/61a26ffd5ad3ece456d74c4c79f7b5e3f440a141
- https://git.kernel.org/stable/c/bb0d8fb35c4ff00a503c2c4dca4cce8d102a21c4
- https://git.kernel.org/stable/c/e192184cf8bce8dd55d619f5611a2eaba996fa05
- https://git.kernel.org/stable/c/ff9fc7ebf5c06de1ef72a69f9b1ab40af8b07f9e
- https://git.kernel.org/stable/c/5e42fca37ccc76f39f73732661bd47254cad5982
- https://git.kernel.org/stable/c/61a26ffd5ad3ece456d74c4c79f7b5e3f440a141
- https://git.kernel.org/stable/c/bb0d8fb35c4ff00a503c2c4dca4cce8d102a21c4
- https://git.kernel.org/stable/c/e192184cf8bce8dd55d619f5611a2eaba996fa05
- https://git.kernel.org/stable/c/ff9fc7ebf5c06de1ef72a69f9b1ab40af8b07f9e
Get alerted when CVE-2022-48789 or the next vulnerability affects your stack