What’s Vulnerable › Vulnerabilities
CVE-2022-4885: sviehb jefferson path traversal
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-11 · updated 2026-06-17
- Weakness: CWE-22
Description
A vulnerability has been found in sviehb jefferson up to 0.3 and classified as critical. This vulnerability affects unknown code of the file src/scripts/jefferson. The manipulation leads to path traversal. The attack can be initiated remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 0.4 is able to address this issue. The name of the patch is 53b3f2fc34af0bb32afbcee29d18213e61471d87. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218020.
Affected products
- sviehb jefferson: before 0.4 — fixed in 0.4
How to fix
Upgrade to a fixed version: sviehb jefferson 0.4. Check the vendor advisory for mitigations.
References
- https://github.com/sviehb/jefferson/commit/53b3f2fc34af0bb32afbcee29d18213e61471d87
- https://github.com/sviehb/jefferson/pull/36
- https://github.com/sviehb/jefferson/releases/tag/v0.4
- https://vuldb.com/?ctiid.218020
- https://vuldb.com/?id.218020
- https://github.com/sviehb/jefferson/commit/53b3f2fc34af0bb32afbcee29d18213e61471d87
- https://github.com/sviehb/jefferson/pull/36
- https://github.com/sviehb/jefferson/releases/tag/v0.4
- https://vuldb.com/?ctiid.218020
- https://vuldb.com/?id.218020
Get alerted when CVE-2022-4885 or the next vulnerability affects your stack