What’s Vulnerable › Vulnerabilities
CVE-2022-48861: vdpa: fix use-after-free on vp_vdpa_remove
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-16 · updated 2026-06-17
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: vdpa: fix use-after-free on vp_vdpa_remove When vp_vdpa driver is unbind, vp_vdpa is freed in vdpa_unregister_device and then vp_vdpa->mdev.pci_dev is dereferenced in vp_modern_remove, triggering use-after-free. Call Trace of unbinding driver free vp_vdpa : do_syscall_64 vfs_write kernfs_fop_write_iter device_release_driver_internal pci_device_remove vp_vdpa_remove vdpa_unregister_device kobject_release device_release kfree Call Trace of dereference vp_vdpa->mdev.pci_dev: vp_modern_remove pci_release_selected_regions pci_release_region pci_resource_len pci_resource_end (dev)->resource[(bar)].end
Affected products
- Linux kernel: from 5.13 before 5.15.29; from 5.16 before 5.16.15 — fixed in 5.15.29, 5.16.15
How to fix
Upgrade to a fixed version: Linux kernel 5.15.29, 5.16.15. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4b1743bc715a3691a63ac21b349079b07bf1b19e
- https://git.kernel.org/stable/c/dc54ba9932aeaaa1a21fe214af1f446593a78274
- https://git.kernel.org/stable/c/eb057b44dbe35ae14527830236a92f51de8f9184
- https://git.kernel.org/stable/c/4b1743bc715a3691a63ac21b349079b07bf1b19e
- https://git.kernel.org/stable/c/dc54ba9932aeaaa1a21fe214af1f446593a78274
- https://git.kernel.org/stable/c/eb057b44dbe35ae14527830236a92f51de8f9184
Get alerted when CVE-2022-48861 or the next vulnerability affects your stack