What’s Vulnerable › Vulnerabilities
CVE-2022-48864: vdpa/mlx5: add validation for VIRTIO_NET_CTRL_MQ_VQ_PAIRS_SET command
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-16 · updated 2026-08-04
- Weakness: CWE-908
Description
In the Linux kernel, the following vulnerability has been resolved: vdpa/mlx5: add validation for VIRTIO_NET_CTRL_MQ_VQ_PAIRS_SET command When control vq receives a VIRTIO_NET_CTRL_MQ_VQ_PAIRS_SET command request from the driver, presently there is no validation against the number of queue pairs to configure, or even if multiqueue had been negotiated or not is unverified. This may lead to kernel panic due to uninitialized resource for the queues were there any bogus request sent down by untrusted driver. Tie up the loose ends there.
Affected products
- Linux kernel: from 5.15 before 5.15.29; from 5.16 before 5.16.15 — fixed in 5.15.29, 5.16.15
How to fix
Upgrade to a fixed version: Linux kernel 5.15.29, 5.16.15. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/9f6effca75626c7a7c7620dabcb1a254ca530230
- https://git.kernel.org/stable/c/e7e118416465f2ba8b55007e5b789823e101421e
- https://git.kernel.org/stable/c/ed0f849fc3a63ed2ddf5e72cdb1de3bdbbb0f8eb
- https://git.kernel.org/stable/c/9f6effca75626c7a7c7620dabcb1a254ca530230
- https://git.kernel.org/stable/c/e7e118416465f2ba8b55007e5b789823e101421e
- https://git.kernel.org/stable/c/ed0f849fc3a63ed2ddf5e72cdb1de3bdbbb0f8eb
Get alerted when CVE-2022-48864 or the next vulnerability affects your stack