What’s Vulnerable › Vulnerabilities
CVE-2022-48885: ice: Fix potential memory leak in ice_gnss_tty_write()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-21 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: ice: Fix potential memory leak in ice_gnss_tty_write() The ice_gnss_tty_write() return directly if the write_buf alloc failed, leaking the cmd_buf. Fix by free cmd_buf if write_buf alloc failed.
Affected products
- Linux kernel: from 6.0 before 6.1.7; 6.2-rc1, 6.2-rc2, 6.2-rc3 — fixed in 6.1.7
How to fix
Upgrade to a fixed version: Linux kernel 6.1.7. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/500ca1da9d0876244eb4d1b0ece6fa0e9968d45d
- https://git.kernel.org/stable/c/f58985620f55580a07d40062c4115d8c9cf6ae27
Get alerted when CVE-2022-48885 or the next vulnerability affects your stack