What’s Vulnerable › Vulnerabilities
CVE-2022-48957: dpaa2-switch: Fix memory leak in dpaa2_switch_acl_entry_add() and dpaa2_switch_acl_entry_remove()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-21 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: dpaa2-switch: Fix memory leak in dpaa2_switch_acl_entry_add() and dpaa2_switch_acl_entry_remove() The cmd_buff needs to be freed when error happened in dpaa2_switch_acl_entry_add() and dpaa2_switch_acl_entry_remove().
Affected products
- Linux kernel: from 5.13 before 5.15.83; from 5.16 before 6.0.13 — fixed in 5.15.83, 6.0.13
How to fix
Upgrade to a fixed version: Linux kernel 5.15.83, 6.0.13. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4fad22a1281c500f15b172c9d261eff347ca634b
- https://git.kernel.org/stable/c/54d830e24247fa8361b016dd2069362866f45cb6
- https://git.kernel.org/stable/c/785ee7a82297e1512d9061aae91699212ed65796
Get alerted when CVE-2022-48957 or the next vulnerability affects your stack