What’s Vulnerable › Vulnerabilities
CVE-2022-48967: NFC: nci: Bounds check struct nfc_target arrays
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-21 · updated 2026-08-04
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: NFC: nci: Bounds check struct nfc_target arrays While running under CONFIG_FORTIFY_SOURCE=y, syzkaller reported: memcpy: detected field-spanning write (size 129) of single field "target->sensf_res" at net/nfc/nci/ntf.c:260 (size 18) This appears to be a legitimate lack of bounds checking in nci_add_new_protocol(). Add the missing checks.
Affected products
- Linux kernel: from 3.4 before 4.9.336; from 4.10 before 4.14.302; from 4.15 before 4.19.269; from 4.20 before 5.4.227; from 5.5 before 5.10.159; from 5.11 before 5.15.83 — fixed in 4.14.302, 4.19.269, 4.9.336, 5.10.159, 5.15.83, 5.4.227
How to fix
Upgrade to a fixed version: Linux kernel 4.14.302, 4.19.269, 4.9.336, 5.10.159. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/27eb2d7a1b9987b6d0429b7716b1ff3b82c4ffc9
- https://git.kernel.org/stable/c/6778434706940b8fad7ef35f410d2b9929f256d2
- https://git.kernel.org/stable/c/6b37f0dc0638d13a006f2f24d2f6ca61e83bc714
- https://git.kernel.org/stable/c/908b2da426fe9c3ce74cf541ba40e7a4251db191
- https://git.kernel.org/stable/c/cff35329070b96b4484d23f9f48a5ca2c947e750
- https://git.kernel.org/stable/c/dbdcfb9f6748218a149f62468d6297ce3f014e9c
- https://git.kernel.org/stable/c/e329e71013c9b5a4535b099208493c7826ee4a64
- https://git.kernel.org/stable/c/f41547546db9af99da2c34e3368664d7a79cefae
Get alerted when CVE-2022-48967 or the next vulnerability affects your stack