What’s Vulnerable › Vulnerabilities
CVE-2022-4898
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-31 · updated 2026-06-17
- Weakness: CWE-79
Description
In affected versions of Octopus Server the help sidebar can be customized to include a Cross-Site Scripting payload in the support link. This was initially resolved in advisory 2022-07 however it was identified that the fix could be bypassed in certain circumstances. A different approach was taken to prevent the possibility of the support link being susceptible to XSS
Affected products
- Octopus Deploy Octopus Server: from 2019.7.0 before 2022.2.8552; from 2022.3.348 before 2022.3.10750; from 2022.4.791 before 2022.4.8319 — fixed in 2022.2.8552, 2022.3.10750, 2022.4.8319
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2022.2.8552, 2022.3.10750, 2022.4.8319. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2022/sa2023-01/
- https://advisories.octopus.com/post/2022/sa2023-01/
Get alerted when CVE-2022-4898 or the next vulnerability affects your stack