What’s Vulnerable › Vulnerabilities
CVE-2022-4900: Potential buffer overflow in php_cli_server_startup_workers
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-02 · updated 2026-06-17
- Weakness: CWE-119
Description
A vulnerability was found in PHP where setting the environment variable PHP_CLI_SERVER_WORKERS to a large value leads to a heap buffer overflow.
Affected products
- PHP: before 8.0.22 — fixed in 8.0.22
- Red Hat Enterprise Linux: 6.0, 7.0, 8.0, 9.0
- RedHat Software Collections: all versions
How to fix
Upgrade to a fixed version: PHP 8.0.22. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2022-4900
- https://bugzilla.redhat.com/show_bug.cgi?id=2179880
- https://security.netapp.com/advisory/ntap-20231130-0008/
- https://access.redhat.com/security/cve/CVE-2022-4900
- https://bugzilla.redhat.com/show_bug.cgi?id=2179880
- https://lists.debian.org/debian-lts-announce/2024/10/msg00011.html
- https://security.netapp.com/advisory/ntap-20231130-0008/
Get alerted when CVE-2022-4900 or the next vulnerability affects your stack