What’s Vulnerable › Vulnerabilities
CVE-2022-49011: hwmon: (coretemp) fix pci device refcount leak in nv1a_ram_new()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-21 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: hwmon: (coretemp) fix pci device refcount leak in nv1a_ram_new() As comment of pci_get_domain_bus_and_slot() says, it returns a pci device with refcount increment, when finish using it, the caller must decrement the reference count by calling pci_dev_put(). So call it after using to avoid refcount leak.
Affected products
- Linux kernel: from 3.14 before 4.9.335; from 4.10 before 4.14.301; from 4.15 before 4.19.268; from 4.20 before 5.4.226; from 5.5 before 5.10.158; from 5.11 before 5.15.82 — fixed in 4.14.301, 4.19.268, 4.9.335, 5.10.158, 5.15.82, 5.4.226
How to fix
Upgrade to a fixed version: Linux kernel 4.14.301, 4.19.268, 4.9.335, 5.10.158. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0dd1da5a15eeecb2fe4cf131b3216fb455af783c
- https://git.kernel.org/stable/c/2f74cffc7c85f770b1b1833dccb03b8cde3be102
- https://git.kernel.org/stable/c/6e035d5a2a6b907cfce9a80c5f442c2e459cd34e
- https://git.kernel.org/stable/c/7dec14537c5906b8bf40fd6fd6d9c3850f8df11d
- https://git.kernel.org/stable/c/bb75a0d1223d43f97089841aecb28a9b4de687a9
- https://git.kernel.org/stable/c/c40db1e5f316792b557d2be37e447c20d9ac4635
- https://git.kernel.org/stable/c/ea5844f946b1ec5c0b7c115cd7684f34fd48021b
- https://git.kernel.org/stable/c/f598da27acbeee414679cacd14294db3e273e3d2
Get alerted when CVE-2022-49011 or the next vulnerability affects your stack