What’s Vulnerable › Vulnerabilities
CVE-2022-49015: net: hsr: Fix potential use-after-free
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-21 · updated 2026-08-04
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: net: hsr: Fix potential use-after-free The skb is delivered to netif_rx() which may free it, after calling this, dereferencing skb may trigger use-after-free.
Affected products
- Linux kernel: from 3.13 before 4.9.335; from 4.10 before 4.14.301; from 4.15 before 4.19.268; from 4.20 before 5.4.226; from 5.5 before 5.10.158; from 5.11 before 5.15.82 — fixed in 4.14.301, 4.19.268, 4.9.335, 5.10.158, 5.15.82, 5.4.226
How to fix
Upgrade to a fixed version: Linux kernel 4.14.301, 4.19.268, 4.9.335, 5.10.158. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4b351609af4fdbc23f79ab2b12748f4403ea9af4
- https://git.kernel.org/stable/c/53a62c5efe91665f7a41fad0f888a96f94dc59eb
- https://git.kernel.org/stable/c/7ca81a161e406834a1fdc405fc83a572bd14b8d9
- https://git.kernel.org/stable/c/7e177d32442b7ed08a9fa61b61724abc548cb248
- https://git.kernel.org/stable/c/8393ce5040803666bfa26a3a7bf41e44fab0ace9
- https://git.kernel.org/stable/c/b35d899854d5d5d58eb7d7e7c0f61afc60d3a9e9
- https://git.kernel.org/stable/c/dca370e575d9b6c983f5015e8dc035e23e219ee6
- https://git.kernel.org/stable/c/f3add2b8cf620966de3ebfa07679ca12d33ec26f
Get alerted when CVE-2022-49015 or the next vulnerability affects your stack