What’s Vulnerable › Vulnerabilities
CVE-2022-49023: wifi: cfg80211: fix buffer overflow in elem comparison
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-21 · updated 2026-08-04
- Weakness: CWE-120
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: cfg80211: fix buffer overflow in elem comparison For vendor elements, the code here assumes that 5 octets are present without checking. Since the element itself is already checked to fit, we only need to check the length.
Affected products
- Linux kernel: from 5.1 before 5.4.226; from 5.5 before 5.10.158; from 5.11 before 5.15.82; from 5.16 before 6.0.12; 6.1-rc1, 6.1-rc2, 6.1-rc3, 6.1-rc4, 6.1-rc5, 6.1-rc6 (+1) — fixed in 5.10.158, 5.15.82, 5.4.226, 6.0.12
How to fix
Upgrade to a fixed version: Linux kernel 5.10.158, 5.15.82, 5.4.226, 6.0.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/391cb872553627bdcf236c03ee7d5adb275e37e1
- https://git.kernel.org/stable/c/88a6fe3707888bd1893e9741157a7035c4159ab6
- https://git.kernel.org/stable/c/9e6b79a3cd17620d467311b30d56f2648f6880aa
- https://git.kernel.org/stable/c/9f16b5c82a025cd4c864737409234ddc44fb166a
- https://git.kernel.org/stable/c/f5c2ec288a865dbe3706b09bed12302e9f6d696b
Get alerted when CVE-2022-49023 or the next vulnerability affects your stack