What’s Vulnerable › Vulnerabilities
CVE-2022-49024: can: m_can: pci: add missing m_can_class_free_dev() in probe/remove methods
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-21 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: can: m_can: pci: add missing m_can_class_free_dev() in probe/remove methods In m_can_pci_remove() and error handling path of m_can_pci_probe(), m_can_class_free_dev() should be called to free resource allocated by m_can_class_allocate_dev(), otherwise there will be memleak.
Affected products
- Linux kernel: from 5.11 before 5.15.82; from 5.16 before 6.0.12; 6.1-rc1, 6.1-rc2, 6.1-rc3, 6.1-rc4, 6.1-rc5, 6.1-rc6 (+1) — fixed in 5.15.82, 6.0.12
How to fix
Upgrade to a fixed version: Linux kernel 5.15.82, 6.0.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0bbb88651ef6b7fbb1bf75ec7ba69add632e834b
- https://git.kernel.org/stable/c/1eca1d4cc21b6d0fc5f9a390339804c0afce9439
- https://git.kernel.org/stable/c/ea8dc27bb044e19868155e500ce397007be98656
Get alerted when CVE-2022-49024 or the next vulnerability affects your stack