What’s Vulnerable › Vulnerabilities
CVE-2022-49027: iavf: Fix error handling in iavf_init_module()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-21 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: iavf: Fix error handling in iavf_init_module() The iavf_init_module() won't destroy workqueue when pci_register_driver() failed. Call destroy_workqueue() when pci_register_driver() failed to prevent the resource leak. Similar to the handling of u132_hcd_init in commit f276e002793c ("usb: u132-hcd: fix resource leak")
Affected products
- Linux kernel: from 4.6 before 5.10.158; from 5.11 before 5.15.82; from 5.16 before 6.0.12; 6.1-rc1, 6.1-rc2, 6.1-rc3, 6.1-rc4, 6.1-rc5, 6.1-rc6 (+1) — fixed in 5.10.158, 5.15.82, 6.0.12
How to fix
Upgrade to a fixed version: Linux kernel 5.10.158, 5.15.82, 6.0.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0d9f5bd54b913018031c5b964fc1f9a31f5f6cb5
- https://git.kernel.org/stable/c/227d8d2f7f2278b8468c5531b0cd0f2a905b4486
- https://git.kernel.org/stable/c/971c55f0763b480e63ceb7a22beb19be2509e5ed
- https://git.kernel.org/stable/c/bd477b891a4fa084561234eed4afacb3001dd359
Get alerted when CVE-2022-49027 or the next vulnerability affects your stack