What’s Vulnerable › Vulnerabilities
CVE-2022-49028: ixgbevf: Fix resource leak in ixgbevf_init_module()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-21 · updated 2026-06-17
- Weakness: CWE-459
Description
In the Linux kernel, the following vulnerability has been resolved: ixgbevf: Fix resource leak in ixgbevf_init_module() ixgbevf_init_module() won't destroy the workqueue created by create_singlethread_workqueue() when pci_register_driver() failed. Add destroy_workqueue() in fail path to prevent the resource leak. Similar to the handling of u132_hcd_init in commit f276e002793c ("usb: u132-hcd: fix resource leak")
Affected products
- Linux kernel: from 4.5 before 5.10.158; from 5.11 before 5.15.82; from 5.16 before 6.0.12; 6.1-rc1, 6.1-rc2, 6.1-rc3, 6.1-rc4, 6.1-rc5, 6.1-rc6 (+1) — fixed in 5.10.158, 5.15.82, 6.0.12
How to fix
Upgrade to a fixed version: Linux kernel 5.10.158, 5.15.82, 6.0.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/7109e941099244cc876a4b3cb7a3ec79f104374a
- https://git.kernel.org/stable/c/8cfa238a48f34038464b99d0b4825238c2687181
- https://git.kernel.org/stable/c/c99671d4699dcf90d6939923c8fe8a8918e140b2
- https://git.kernel.org/stable/c/f166c62cad798c53300b4b327e44300c73ec492d
Get alerted when CVE-2022-49028 or the next vulnerability affects your stack