What’s Vulnerable › Vulnerabilities
CVE-2022-49035: media: s5p_cec: limit msg.len to CEC_MAX_MSG_SIZE
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-02 · updated 2026-06-17
- Weakness: CWE-770
Description
In the Linux kernel, the following vulnerability has been resolved: media: s5p_cec: limit msg.len to CEC_MAX_MSG_SIZE I expect that the hardware will have limited this to 16, but just in case it hasn't, check for this corner case.
Affected products
- Linux kernel: before 4.9.333; from 4.10 before 4.14.299; from 4.15 before 4.19.265; from 4.20 before 5.4.224; from 5.5 before 5.10.154; from 5.11 before 5.15.78 — fixed in 4.14.299, 4.19.265, 4.9.333, 5.10.154, 5.15.78, 5.4.224
How to fix
Upgrade to a fixed version: Linux kernel 4.14.299, 4.19.265, 4.9.333, 5.10.154. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1609231f86760c1f6a429de7913dd795b9faa08c
- https://git.kernel.org/stable/c/2654e785bd4aa2439cdffbe7dc1ea30a0eddbfe4
- https://git.kernel.org/stable/c/4a449430ecfb199b99ba58af63c467eb53500b39
- https://git.kernel.org/stable/c/7ccb40f26cbefa1c6dfd3418bea54c9518cdbd8a
- https://git.kernel.org/stable/c/93f65ce036863893c164ca410938e0968964b26c
- https://git.kernel.org/stable/c/a2728bf9b6c65e46468c763e3dab7e04839d4e11
- https://git.kernel.org/stable/c/cbfa26936f318b16ccf9ca31b8e8b30c0dc087bd
- https://git.kernel.org/stable/c/fc0f76dd5f116fa9291327024dda392f8b4e849c
Get alerted when CVE-2022-49035 or the next vulnerability affects your stack