What’s Vulnerable › Vulnerabilities
CVE-2022-49040
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-26 · updated 2026-06-17
- Weakness: CWE-120
Description
Buffer copy without checking size of input ('Classic Buffer Overflow') vulnerability in connection management functionality in Synology Drive Client before 3.4.0-15721 allows local users with administrator privileges to crash the client via unspecified vectors.
Affected products
- Synology Drive Client: before 3.4.0-15721 — fixed in 3.4.0-15721
How to fix
Upgrade to a fixed version: Synology Drive Client 3.4.0-15721. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-49040 or the next vulnerability affects your stack