What’s Vulnerable › Vulnerabilities
CVE-2022-49042
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-03 · updated 2026-07-22
- Weakness: CWE-829
Description
An inclusion of functionality from untrusted control sphere vulnerability in MinGW DLL component in Synology Hyper Backup Explorer before 3.0.1-0156 allows local users to execute arbitrary code via unspecified vectors.
Affected products
- Synology Hyper Backup Explorer: before 3.0.1-0156 — fixed in 3.0.1-0156
How to fix
Upgrade to a fixed version: Synology Hyper Backup Explorer 3.0.1-0156. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-49042 or the next vulnerability affects your stack