What’s Vulnerable › Vulnerabilities
CVE-2022-49043
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-26 · updated 2026-06-17
- Weakness: CWE-416
Description
xmlXIncludeAddNode in xinclude.c in libxml2 before 2.11.0 has a use-after-free.
Affected products
- xmlsoft libxml2: before 2.11.0 — fixed in 2.11.0
How to fix
Upgrade to a fixed version: xmlsoft libxml2 2.11.0. Check the vendor advisory for mitigations.
References
- https://github.com/php/php-src/issues/17467
- https://gitlab.gnome.org/GNOME/libxml2/-/commit/5a19e21605398cef6a8b1452477a8705cb41562b
- https://lists.debian.org/debian-lts-announce/2025/02/msg00028.html
Get alerted when CVE-2022-49043 or the next vulnerability affects your stack