What’s Vulnerable › Vulnerabilities
CVE-2022-49058: cifs: potential buffer overflow in handling symlinks
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-08-04
- Weakness: CWE-120
Description
In the Linux kernel, the following vulnerability has been resolved: cifs: potential buffer overflow in handling symlinks Smatch printed a warning: arch/x86/crypto/poly1305_glue.c:198 poly1305_update_arch() error: __memcpy() 'dctx->buf' too small (16 vs u32max) It's caused because Smatch marks 'link_len' as untrusted since it comes from sscanf(). Add a check to ensure that 'link_len' is not larger than the size of the 'link_str' buffer.
Affected products
- Linux kernel: from 2.6.37 before 4.9.311; from 4.10 before 4.14.276; from 4.15 before 4.19.239; from 4.20 before 5.4.190; from 5.5 before 5.10.112; from 5.11 before 5.15.35 — fixed in 4.14.276, 4.19.239, 4.9.311, 5.10.112, 5.15.35, 5.17.4
How to fix
Upgrade to a fixed version: Linux kernel 4.14.276, 4.19.239, 4.9.311, 5.10.112. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1316c28569a80ab3596eeab05bf5e01991e7e739
- https://git.kernel.org/stable/c/22d658c6c5affed10c8907e67160cef0b6c92186
- https://git.kernel.org/stable/c/3e582749e742e662a8e9bb37cffac62dccaaa1e2
- https://git.kernel.org/stable/c/4e166a41180be2f1e66bbb6d46448e80a9a5ec05
- https://git.kernel.org/stable/c/515e7ba11ef043d6febe69389949c8ef5f25e9d0
- https://git.kernel.org/stable/c/64c4a37ac04eeb43c42d272f6e6c8c12bfcf4304
- https://git.kernel.org/stable/c/9901b07ba42b39266b34a888e48d7306fd707bee
- https://git.kernel.org/stable/c/eb5f51756944735ac70cd8bb38637cc202e29c91
Get alerted when CVE-2022-49058 or the next vulnerability affects your stack