What’s Vulnerable › Vulnerabilities
CVE-2022-49088: dpaa2-ptp: Fix refcount leak in dpaa2_ptp_probe
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: dpaa2-ptp: Fix refcount leak in dpaa2_ptp_probe This node pointer is returned by of_find_compatible_node() with refcount incremented. Calling of_node_put() to aovid the refcount leak.
Affected products
- Linux kernel: from 5.3 before 5.4.189; from 5.5 before 5.10.111; from 5.11 before 5.15.34; from 5.16 before 5.16.20; from 5.17 before 5.17.3; 5.18-rc1 — fixed in 5.10.111, 5.15.34, 5.16.20, 5.17.3, 5.4.189
How to fix
Upgrade to a fixed version: Linux kernel 5.10.111, 5.15.34, 5.16.20, 5.17.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2b04bd4f03bba021959ca339314f6739710f0954
- https://git.kernel.org/stable/c/45fdd98b70142521739615ad1bfb760401863b73
- https://git.kernel.org/stable/c/46d120f7c163706d6c31ee00baa0be64c4572b78
- https://git.kernel.org/stable/c/599874bbc4ed832ccb578d48ac0ae7344382ef43
- https://git.kernel.org/stable/c/ebd1e3458dbf6643aa0272da398cb5b537d492b7
- https://git.kernel.org/stable/c/fbe5f4c0dd3475178f17ddd8b8d5044ebeae0be7
Get alerted when CVE-2022-49088 or the next vulnerability affects your stack