What’s Vulnerable › Vulnerabilities
CVE-2022-49115: PCI: endpoint: Fix misused goto label
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: PCI: endpoint: Fix misused goto label Fix a misused goto label jump since that can result in a memory leak.
Affected products
- Linux kernel: before 5.10.111; from 5.11 before 5.15.34; from 5.16 before 5.16.20; from 5.17 before 5.17.3 — fixed in 5.10.111, 5.15.34, 5.16.20, 5.17.3
How to fix
Upgrade to a fixed version: Linux kernel 5.10.111, 5.15.34, 5.16.20, 5.17.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/70236a0d2d62b081d52076de22d8d017d6cbe99f
- https://git.kernel.org/stable/c/7c657c0694ff690e361a13ce41c36b9dfb433ec8
- https://git.kernel.org/stable/c/bf8d87c076f55b8b4dfdb6bc6c6b6dc0c2ccb487
- https://git.kernel.org/stable/c/d3642fc64276b06446290f82fd45630aeaa4b007
- https://git.kernel.org/stable/c/dc9d33b2d8d09e6478e8ef817a81cf26930acc3e
Get alerted when CVE-2022-49115 or the next vulnerability affects your stack