What’s Vulnerable › Vulnerabilities
CVE-2022-49119: scsi: pm8001: Fix memory leak in pm8001_chip_fw_flash_update_req()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: pm8001: Fix memory leak in pm8001_chip_fw_flash_update_req() In pm8001_chip_fw_flash_update_build(), if pm8001_chip_fw_flash_update_build() fails, the struct fw_control_ex allocated must be freed.
Affected products
- Linux kernel: before 5.10.111; from 5.11 before 5.15.34; from 5.16 before 5.16.20; from 5.17 before 5.17.3 — fixed in 5.10.111, 5.15.34, 5.16.20, 5.17.3
How to fix
Upgrade to a fixed version: Linux kernel 5.10.111, 5.15.34, 5.16.20, 5.17.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/a25ed5f21f94f9ae4bcc8dd747e978668890c921
- https://git.kernel.org/stable/c/d83574666bac4b1462e90df393fbed6c5f57d1a3
- https://git.kernel.org/stable/c/e5ecdb01952f230921aa8163d8d7f4c97c925ed8
- https://git.kernel.org/stable/c/f792a3629f4c4aa4c3703d66b43ce1edcc3ec09a
- https://git.kernel.org/stable/c/fe5b8ea5583b5c3f6f68e06acba50387edf3b5d5
Get alerted when CVE-2022-49119 or the next vulnerability affects your stack