What’s Vulnerable › Vulnerabilities
CVE-2022-49122: dm ioctl: prevent potential spectre v1 gadget
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: dm ioctl: prevent potential spectre v1 gadget It appears like cmd could be a Spectre v1 gadget as it's supplied by a user and used as an array index. Prevent the contents of kernel memory from being leaked to userspace via speculative execution by using array_index_nospec.
Affected products
- Linux kernel: before 4.9.311; from 4.10 before 4.14.276; from 4.15 before 4.19.238; from 4.20 before 5.4.189; from 5.5 before 5.10.111; from 5.11 before 5.15.34 — fixed in 4.14.276, 4.19.238, 4.9.311, 5.10.111, 5.15.34, 5.16.20
How to fix
Upgrade to a fixed version: Linux kernel 4.14.276, 4.19.238, 4.9.311, 5.10.111. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/02cc46f397eb3691c56affbd5073e54f7a82ac32
- https://git.kernel.org/stable/c/0320bac5801b31407200227173205d017488f140
- https://git.kernel.org/stable/c/44e6cb3ab177faae840bb2c1ebda9a2539876184
- https://git.kernel.org/stable/c/58880025e3362024f6d8ea01cb0c7a5df6c84ba6
- https://git.kernel.org/stable/c/71c8df33fd777c7628f6fbc09b14e84806c55914
- https://git.kernel.org/stable/c/76c94651005f58885facf9c973007f5ea01ab01f
- https://git.kernel.org/stable/c/7ae2c5b89da3cfaf856df880af27d3bb32a74b3d
- https://git.kernel.org/stable/c/cd9c88da171a62c4b0f1c70e50c75845969fbc18
- https://git.kernel.org/stable/c/dd86064417de828ff2102ddc6049c829bf7585b4
Get alerted when CVE-2022-49122 or the next vulnerability affects your stack