What’s Vulnerable › Vulnerabilities
CVE-2022-49126: scsi: mpi3mr: Fix memory leaks
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-08-13
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: mpi3mr: Fix memory leaks Fix memory leaks related to operational reply queue's memory segments which are not getting freed while unloading the driver.
Affected products
- Linux kernel: before 5.15.34; from 5.16 before 5.16.20; from 5.17 before 5.17.3 — fixed in 5.15.34, 5.16.20, 5.17.3
How to fix
Upgrade to a fixed version: Linux kernel 5.15.34, 5.16.20, 5.17.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/27fc9e90171ab0a94a411f3fdb3522ef5acb9537
- https://git.kernel.org/stable/c/5d76a88b8536d75ff5362e232097e85946b8aadf
- https://git.kernel.org/stable/c/71c7ac65a084ae7d387c3c1d02d59edfdecb009f
- https://git.kernel.org/stable/c/d44b5fefb22e139408ae12b864da1ecb9ad9d1d2
Get alerted when CVE-2022-49126 or the next vulnerability affects your stack