What’s Vulnerable › Vulnerabilities
CVE-2022-49186: clk: visconti: prevent array overflow in visconti_clk_register_gates()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: clk: visconti: prevent array overflow in visconti_clk_register_gates() This code was using -1 to represent that there was no reset function. Unfortunately, the -1 was stored in u8 so the if (clks[i].rs_id >= 0) condition was always true. This lead to an out of bounds access in visconti_clk_register_gates().
Affected products
- Linux kernel: from 5.17 before 5.17.2 — fixed in 5.17.2
How to fix
Upgrade to a fixed version: Linux kernel 5.17.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2723543c1d60278d5aef1c4ad732dbad24b84a81
- https://git.kernel.org/stable/c/c5601e0720ce1a3ad895f94a5838530edde01ed3
Get alerted when CVE-2022-49186 or the next vulnerability affects your stack