What’s Vulnerable › Vulnerabilities
CVE-2022-49199: RDMA/nldev: Prevent underflow in nldev_stat_set_counter_dynamic_doit()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-191
Description
In the Linux kernel, the following vulnerability has been resolved: RDMA/nldev: Prevent underflow in nldev_stat_set_counter_dynamic_doit() This code checks "index" for an upper bound but it does not check for negatives. Change the type to unsigned to prevent underflows.
Affected products
- Linux kernel: from 5.16 before 5.16.19; from 5.17 before 5.17.2 — fixed in 5.16.19, 5.17.2
How to fix
Upgrade to a fixed version: Linux kernel 5.16.19, 5.17.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2a495ef04d5f42e6f00eb2bec1ee9075e3d5a771
- https://git.kernel.org/stable/c/87e0eacb176f9500c2063d140c0a1d7fa51ab8a5
- https://git.kernel.org/stable/c/f6dd8669b8299a3a536cd92a7069152a7704da1d
Get alerted when CVE-2022-49199 or the next vulnerability affects your stack