What’s Vulnerable › Vulnerabilities
CVE-2022-49222: drm/bridge: anx7625: Fix overflow issue on reading EDID
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: drm/bridge: anx7625: Fix overflow issue on reading EDID The length of EDID block can be longer than 256 bytes, so we should use `int` instead of `u8` for the `edid_pos` variable.
Affected products
- Linux kernel: from 5.11 before 5.15.33; from 5.16 before 5.16.19; from 5.17 before 5.17.2 — fixed in 5.15.33, 5.16.19, 5.17.2
How to fix
Upgrade to a fixed version: Linux kernel 5.15.33, 5.16.19, 5.17.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/64c06df2428bb7bb3d8cf5691416001af42d94dd
- https://git.kernel.org/stable/c/d5c6f647aec9ed524aedd04a3aec5ebc21d39007
- https://git.kernel.org/stable/c/db1c47d299298a7c52ccb201905d6be979fd7507
- https://git.kernel.org/stable/c/f0d5d938d51af4eb08d9d8684fd9903425a0a87d
Get alerted when CVE-2022-49222 or the next vulnerability affects your stack