What’s Vulnerable › Vulnerabilities
CVE-2022-49249: ASoC: codecs: wc938x: fix accessing array out of bounds for enum type
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: ASoC: codecs: wc938x: fix accessing array out of bounds for enum type Accessing enums using integer would result in array out of bounds access on platforms like aarch64 where sizeof(long) is 8 compared to enum size which is 4 bytes. Fix this by using enumerated items instead of integers.
Affected products
- Linux kernel: from 5.14 before 5.15.33; from 5.16 before 5.16.19; from 5.17 before 5.17.2 — fixed in 5.15.33, 5.16.19, 5.17.2
How to fix
Upgrade to a fixed version: Linux kernel 5.15.33, 5.16.19, 5.17.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/adafea71b49ec4dbc44e0b84ec6eb602004a7a08
- https://git.kernel.org/stable/c/cc587b7c8fbbe128f6bd0dad025a0caea5e6d164
- https://git.kernel.org/stable/c/d09aee1b1da196be11ed86dd4897f228f2487613
- https://git.kernel.org/stable/c/f03c0c94186d5876857132d97e28f20cdc100bdc
Get alerted when CVE-2022-49249 or the next vulnerability affects your stack