What’s Vulnerable › Vulnerabilities
CVE-2022-49251: ASoC: codecs: va-macro: fix accessing array out of bounds for enum type
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: ASoC: codecs: va-macro: fix accessing array out of bounds for enum type Accessing enums using integer would result in array out of bounds access on platforms like aarch64 where sizeof(long) is 8 compared to enum size which is 4 bytes.
Affected products
- Linux kernel: from 5.11 before 5.15.33; from 5.16 before 5.16.19; from 5.17 before 5.17.2 — fixed in 5.15.33, 5.16.19, 5.17.2
How to fix
Upgrade to a fixed version: Linux kernel 5.15.33, 5.16.19, 5.17.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0ea5eff7c6063a8f124188424f8e4c6727f35051
- https://git.kernel.org/stable/c/4a799972a283ab4ec031041304d7e2d34e1a16eb
- https://git.kernel.org/stable/c/966408e37d84b762d11978b7bfb03fff0c6222ad
- https://git.kernel.org/stable/c/c0099bbf8bc85d30c4cf38220fca3c8d4253fa7f
Get alerted when CVE-2022-49251 or the next vulnerability affects your stack