What’s Vulnerable › Vulnerabilities
CVE-2022-49252: ASoC: codecs: rx-macro: fix accessing array out of bounds for enum type
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: ASoC: codecs: rx-macro: fix accessing array out of bounds for enum type Accessing enums using integer would result in array out of bounds access on platforms like aarch64 where sizeof(long) is 8 compared to enum size which is 4 bytes.
Affected products
- Linux kernel: from 5.12 before 5.15.33; from 5.16 before 5.16.19; from 5.17 before 5.17.2 — fixed in 5.15.33, 5.16.19, 5.17.2
How to fix
Upgrade to a fixed version: Linux kernel 5.15.33, 5.16.19, 5.17.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/7e3629e256d1cabf801d00050550ade4d036cafe
- https://git.kernel.org/stable/c/aed43e92e4b9187029903880d5db608f7fa1c53c
- https://git.kernel.org/stable/c/bcfe5f76cc4051ea3f9eb5d2c8ea621641f290a5
- https://git.kernel.org/stable/c/eb15c6ea692fd88d70698d874d9a0d667fb4cde9
Get alerted when CVE-2022-49252 or the next vulnerability affects your stack