What’s Vulnerable › Vulnerabilities
CVE-2022-49275: can: m_can: m_can_tx_handler(): fix use after free of skb
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: can: m_can: m_can_tx_handler(): fix use after free of skb can_put_echo_skb() will clone skb then free the skb. Move the can_put_echo_skb() for the m_can version 3.0.x directly before the start of the xmit in hardware, similar to the 3.1.x branch.
Affected products
- Linux kernel: from 3.18 before 4.9.324; from 4.10 before 4.14.289; from 4.15 before 4.19.253; from 4.20 before 5.4.207; from 5.5 before 5.10.110; from 5.11 before 5.15.33 — fixed in 4.14.289, 4.19.253, 4.9.324, 5.10.110, 5.15.33, 5.16.19
How to fix
Upgrade to a fixed version: Linux kernel 4.14.289, 4.19.253, 4.9.324, 5.10.110. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/08d90846e438ac22dc56fc49ec0b0d195831c5ed
- https://git.kernel.org/stable/c/2e8e79c416aae1de224c0f1860f2e3350fa171f8
- https://git.kernel.org/stable/c/31417073493f302d26ab66b3abc098d43227b835
- https://git.kernel.org/stable/c/4db7d6f481990dd179a9ee7126dc7aa31ea4fff3
- https://git.kernel.org/stable/c/7728d937ec403a1ceff9483023252d2cb8777f81
- https://git.kernel.org/stable/c/869016a2938ac44f7b2fb7fc22c89edad99eb9b3
- https://git.kernel.org/stable/c/d3892a747ab16b1eb6593a19d29f62c3b3f020ac
- https://git.kernel.org/stable/c/d93ed9aff64968f4cdad690712eb4f48ae537bde
- https://git.kernel.org/stable/c/f43e64076ff1b1dcb893fb77ad1204105f710a29
Get alerted when CVE-2022-49275 or the next vulnerability affects your stack