What’s Vulnerable › Vulnerabilities
CVE-2022-49279: NFSD: prevent integer overflow on 32 bit systems
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-08-04
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: NFSD: prevent integer overflow on 32 bit systems On a 32 bit system, the "len * sizeof(*p)" operation can have an integer overflow.
Affected products
- Linux kernel: before 4.19.238; from 4.20 before 5.4.189; from 5.5 before 5.10.110; from 5.11 before 5.15.33; from 5.16 before 5.16.19; from 5.17 before 5.17.2 — fixed in 4.19.238, 5.10.110, 5.15.33, 5.16.19, 5.17.2, 5.4.189
How to fix
Upgrade to a fixed version: Linux kernel 4.19.238, 5.10.110, 5.15.33, 5.16.19. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/23a9dbbe0faf124fc4c139615633b9d12a3a89ef
- https://git.kernel.org/stable/c/303cd6173dce0a28d26526c77814eb90a41bd898
- https://git.kernel.org/stable/c/3a2789e8ccb4a3e2a631f6817a2d3bb98b8c4fd8
- https://git.kernel.org/stable/c/79b1c54fc6ce09ee0d5fe088bb3de26ae2150e3c
- https://git.kernel.org/stable/c/7af164fa2f1abc577d357d22d83a2f3490875d7e
- https://git.kernel.org/stable/c/ce1aa09cc14ed625104acc2d487bd92b9a88efe2
- https://git.kernel.org/stable/c/e4195d27306ea468a6dc3a27af6f586709951229
Get alerted when CVE-2022-49279 or the next vulnerability affects your stack