What’s Vulnerable › Vulnerabilities
CVE-2022-4928: icplayer presenter.js AddonText_Selection_create cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-06 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in icplayer up to 0.819. It has been declared as problematic. Affected by this vulnerability is the function AddonText_Selection_create of the file addons/Text_Selection/src/presenter.js. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.820 is able to address this issue. The identifier of the patch is 2223628e6db1df73f6d633d2c0422d995990f0a3. It is recommended to upgrade the affected component. The identifier VDB-222289 was assigned to this vulnerability.
Affected products
- icplayer: before 0.820 — fixed in 0.820
How to fix
Upgrade to a fixed version: icplayer 0.820. Check the vendor advisory for mitigations.
References
- https://github.com/icplayer/icplayer/commit/2223628e6db1df73f6d633d2c0422d995990f0a3
- https://github.com/icplayer/icplayer/pull/881
- https://github.com/icplayer/icplayer/releases/tag/v0.820
- https://vuldb.com/?ctiid.222289
- https://vuldb.com/?id.222289
- https://github.com/icplayer/icplayer/commit/2223628e6db1df73f6d633d2c0422d995990f0a3
- https://github.com/icplayer/icplayer/pull/881
- https://github.com/icplayer/icplayer/releases/tag/v0.820
- https://vuldb.com/?ctiid.222289
- https://vuldb.com/?id.222289
Get alerted when CVE-2022-4928 or the next vulnerability affects your stack