What’s Vulnerable › Vulnerabilities
CVE-2022-49280: NFSD: prevent underflow in nfssvc_decode_writeargs()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-08-04
- Weakness: CWE-191
Description
In the Linux kernel, the following vulnerability has been resolved: NFSD: prevent underflow in nfssvc_decode_writeargs() Smatch complains: fs/nfsd/nfsxdr.c:341 nfssvc_decode_writeargs() warn: no lower bound on 'args->len' Change the type to unsigned to prevent this issue.
Affected products
- Linux kernel: before 4.9.311; from 4.10 before 4.14.276; from 4.15 before 4.19.238; from 4.20 before 5.4.189; from 5.5 before 5.10.110; from 5.11 before 5.15.33 — fixed in 4.14.276, 4.19.238, 4.9.311, 5.10.110, 5.15.33, 5.16.19
How to fix
Upgrade to a fixed version: Linux kernel 4.14.276, 4.19.238, 4.9.311, 5.10.110. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/184416d4b98509fb4c3d8fc3d6dc1437896cc159
- https://git.kernel.org/stable/c/2764af8ce0bf03cc43ee4a11897cab96bde6caae
- https://git.kernel.org/stable/c/413d8fefafe531a9442bb623e3fe292a38f88d65
- https://git.kernel.org/stable/c/614a61e1592051cc42d3c38f899c9f7bdaad8a1d
Get alerted when CVE-2022-49280 or the next vulnerability affects your stack